booting off wrong drive

Discussion in 'Tech' started by funkgab, Jun 24, 2012.

  1. funkgab

    funkgab Junior Member

    Messages:
    2,279
    Trophy Points:
    53
    Location:
    Los Angeles, California
    I have a Gigabyte GA-Z68X-UD3H-B3 mobo
    so my current bootdrive is running off an SSD (Crucial m4 120 gb)

    if i completely shutoff my computer, it keeps seeing my samsung storage drive as IDE and moves it up on the boot priority list even though the m4 is set on primary..

    it sees it as an IDE MASTER channel, is there any way to set it as a slave channel?

    all my other storage drivers, and the ssd is shown as scsi, this is very annoying, as when i try to boot my computer from a full shutdown, it keeps booting from the wrong drive, thus failing to boot
  2. Tacdriver

    Tacdriver Junior Member

    Messages:
    3,085
    Trophy Points:
    53
    Have you checked the 2 pin jumper on the drive to ensure it's not set as the Primary.............if there is a jumper that is?
  3. PeNZ

    PeNZ Tweak OG

    Messages:
    1,632
    Trophy Points:
    51
    Location:
    Waukesha, WI
    Kinda sounds like your CMOS might be clearing on power down, check the battery, also check for a BIOS update.
  4. funkgab

    funkgab Junior Member

    Messages:
    2,279
    Trophy Points:
    53
    Location:
    Los Angeles, California
    tacdriver - no jumpers, PeNZ - Bios update didn't do it, battery seems fine..

    I reset the bios back to stock, rolled it back to what it was before (version wise) then i upgraded it again, and tried messing with some AHCI settings, seems to be fine now for now